ドキュメントには頻繁に更新が加えられ、その都度公開されています。本ページの翻訳はまだ未完成な部分があることをご了承ください。最新の情報については、英語のドキュメンテーションをご参照ください。本ページの翻訳に問題がある場合はこちらまでご連絡ください。
記事のバージョン: GitHub.com

ページビルド失敗: 無効なハイライト言語

GitHub Pages のコードが無効な言語 ID で highlighter タグを使用している場合、GitHub Pages サイトはビルドされません。

無効なハイライト言語を指定しているために GitHub Pages サイトのビルドに失敗した場合は、次のようなメールが届きます:

件名: Page build failed

The page build failed with the following error:

The highlighter language identifier invalidlanguage is invalid.

無効なハイライト言語によるエラーのトラブルシューティング

参考: GitHub へプッシュする前にデバッグとビルドエラーの修正を簡単に行えるよう、Jekyll をローカルで実行 することを強くおすすめします。トラブルシューティングの選択肢についてさらに学ぶには、「GitHub Pages のビルドのトラブルシューティング」を参照してください。

Rouge は Jekyll のデフォルトの構文ハイライトで、Pygments ハイライターと互換性があります。 以下の点を確認してください:

参考リンク

担当者にお尋ねください

探しているものが見つからなかったでしょうか?

弊社にお問い合わせください