ドキュメントには頻繁に更新が加えられ、その都度公開されています。本ページの翻訳はまだ未完成な部分があることをご了承ください。最新の情報については、英語のドキュメンテーションをご参照ください。本ページの翻訳に問題がある場合はこちらまでご連絡ください。

GitHubホストランナーにインストールされるソフトウェア

この記事は、GitHubがホストする仮想環境で利用できるパッケージとツールのリファレンスです。

GitHub Actions is available with GitHub Free, GitHub Pro, GitHub Team, and GitHub Enterprise Cloud. GitHub Actions is unavailable for per-repository plans, which are legacy billing plans. For more information, see "GitHub's products."

ここには以下の内容があります:

リクエストしたいツールがある場合、actions/virtual-environments で Issue を開いてください。

Ubuntu 16.04 LTS

  • 7-Zip 9.20

  • Ansible (ansible 2.8.6)

  • AzCopy (azcopy 7.3.0-netcore)

  • Azure CLI (azure-cli 2.0.75)

  • Azure CLI (azure-devops 0.13.0)

  • Basic CLI:

    • curl
    • dnsutils
    • ファイル
    • ftp
    • iproute2
    • iputils-ping
    • jq
    • libcurl3
    • libicu55
    • libunwind8
    • locales
    • netcat
    • openssh-client
    • rsync
    • shellcheck
    • sudo
    • telnet
    • time
    • unzip
    • wget
    • zip
    • tzdata
  • AWS CLI (aws-cli/1.16.266 Python/2.7.12 Linux/4.15.0-1057-azure botocore/1.13.2)

  • build-essential

  • Clang 6.0 (clang バージョン 6.0.1-svn334776-1~exp1~20190309042730.123 (branches/release_60))

  • CMake (cmake バージョン 3.12.4)

  • Docker Compose (docker-compose バージョン 1.22.0、ビルド f46880fe)

  • Docker (Docker バージョン 3.0.8, ビルド 2355349d)

  • .NET Core SDK:

    • 2.2.402
    • 2.2.401
    • 2.2.301
    • 2.2.300
    • 2.2.206
    • 2.2.205
    • 2.2.204
    • 2.2.203
    • 2.2.202
    • 2.2.109
    • 2.2.108
    • 2.2.107
    • 2.2.106
    • 2.2.105
    • 2.2.104
    • 2.2.103
    • 2.2.102
    • 2.2.101
    • 2.2.100
    • 2.1.802
    • 2.1.801
    • 2.1.701
    • 2.1.700
    • 2.1.606
    • 2.1.605
    • 2.1.604
    • 2.1.603
    • 2.1.602
    • 2.1.509
    • 2.1.508
    • 2.1.507
    • 2.1.506
    • 2.1.505
    • 2.1.504
    • 2.1.503
    • 2.1.502
    • 2.1.500
    • 2.1.403
    • 2.1.402
    • 2.1.401
    • 2.1.302
    • 2.1.301
    • 2.1.300
  • Erlang (Erlang (SMP,ASYNC_THREADS,HIPE) (BEAM) エミュレーターバージョン 10.5.3)

  • Firefox (Mozilla Firefox 70.0)

  • GNU C++ 7.4.0

  • Git (2.23.0)

  • Git Large File Storage (LFS) (2.9.0)

  • Go 1.9 (go バージョン go1.9.7 linux/amd64)

  • Go 1.10 (go バージョン go1.10.8 linux/amd64)

  • Go 1.11 (go バージョン go1.11.12 linux/amd64)

  • Go 1.12 (go バージョン go1.12.7 linux/amd64)

  • Go 1.13 (go バージョン go1.13 linux/amd64)

  • Google Chrome (Google Chrome 78.0.3904.70 )

  • Google Cloud SDK (268.0.0)

  • Haskell Cabal (cabal-install バージョン 2.0.0.1 バージョン2.0.1.1の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 2.2.0.0 バージョン2.2.0.1の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 2.4.1.0 バージョン2.4.1.0の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 3.0.0.0 バージョン3.0.0.0の Cabalライブラリでコンパイル)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.0.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.2.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.4.4)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.3)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.4)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.5)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.8.1)

  • Haskell Stack (バージョン 2.1.3, Git リビジョン 636e3a759d51127df2b62f90772def126cdf6d1f (7735 commits) x86_64 hpack-0.31.2)

  • Heroku (heroku/7.33.3 linux-x64 node-v11.14.0)

  • HHVM (HipHop VM 4.28.1 (rel))

  • ImageMagick

  • Azul Zulu OpenJDK (7) (openjdk バージョン "1.7.0_242")

  • Azul Zulu OpenJDK (8) (openjdk バージョン "1.8.0_232")

  • Azul Zulu OpenJDK (11) (openjdk バージョン "11.0.5" 2019-10-15 LTS)

  • Azul Zulu OpenJDK (12) (openjdk バージョン "12.0.2" 2019-07-16)

  • Ant (Apache Ant(TM) バージョン 1.9.6、2018 年 7 月 20 日にコンパイル)

  • Gradle 5.6.3

  • Maven (Apache Maven 3.6.1 (d66c9c0b3152b2e69ee9bac180bb8fcc8e6af555; 2019-04-04T19:00:29Z))

  • Kind (v0.5.1)

  • kubectl (クライアントバージョン: v1.16.2)

  • helm (クライアント: v2.15.1+gcf1de4f)

  • Leiningen (Leiningen 2.9.1 on Java 1.8.0_232 OpenJDK 64-Bit Server VM)

  • Mercurial (Mercurial Distributed SCM (バージョン 4.4.1))

  • Miniconda (conda 4.7.12)

  • Mono (Mono JIT コンパイラバージョン 6.4.0.198 (tarball Tue Sep 24 01:20:30 UTC 2019))

  • MySQL (mysql Ver 14.14 Distrib 5.7.27, for Linux (x86_64) using EditLine wrapper)

  • MySQL Server (user:root password:root)

  • MS SQL Server Client Tools

  • Node.js (v12.13.0)

  • Bower (1.8.8)

  • Grunt (grunt-cli v1.2.0)

  • Gulp (CLI バージョン: 2.2.0 ローカルバージョン: 不明)

  • n (6.0.1)

  • Parcel (1.12.4)

  • TypeScript (バージョン 3.6.4)

  • Webpack (4.41.2)

  • Webpack CLI (3.3.9)

  • Yarn (1.19.1)

  • PhantomJS (2.1.1)

  • PHP 5.6 (PHP 5.6.40-13+ubuntu16.04.1+deb.sury.org+1 (cli) )

  • PHP 7.0 (PHP 7.0.33-12+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 19:00:13) ( NTS ))

  • PHP 7.1 (PHP 7.1.32-2+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:43:29) ( NTS ))

  • PHP 7.2 (PHP 7.2.24-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:28:51) ( NTS ))

  • PHP 7.3 (PHP 7.3.11-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:23:06) ( NTS ))

  • Composer (Composer バージョン 1.9.0 2019-08-02 20:55:32)

  • PHPUnit (PHPUnit 7.5.16 by Sebastian Bergmann and contributors.)

  • Pollinate

  • Powershell (PowerShell 6.2.3)

  • rustup (1.20.2)

  • rust (1.38.0)

  • cargo (1.38.0)

  • rustfmt (1.4.4-stable)

  • clippy (0.0.212)

  • rustdoc (1.38.0)

  • bindgen (execute the 0.51.1)

  • cbindgen (0.9.1)

  • sbt (1.3.3)

  • Sphinx Open Source Search Server

  • Subversion (svn、バージョン 1.9.3 (r1718519))

  • Terraform (Terraform v0.12.12)

  • Vcpkg 2019.09.12-unknownhash

  • Zeit Now CLI (16.4.0)

  • Google Repository 58

  • Google Play services 49

  • Google APIs 24

  • Google APIs 23

  • Google APIs 22

  • Google APIs 21

  • CMake 3.6.4111459

  • Android Support Repository 47.0.0

  • Android Solver for ConstraintLayout 1.0.2

  • Android Solver for ConstraintLayout 1.0.1

  • Android SDK Platform-Tools 29.0.4

  • Android SDK Platform 29

  • Android SDK Platform 28

  • Android SDK Platform 27

  • Android SDK Platform 26

  • Android SDK Platform 25

  • Android SDK Platform 24

  • Android SDK Platform 23

  • Android SDK Platform 22

  • Android SDK Platform 21

  • Android SDK Platform 19

  • Android SDK Platform 17

  • Android SDK Platform 15

  • Android SDK Platform 10

  • Android SDK Patch Applier v4

  • Android SDK Build-Tools 29.0.2

  • Android SDK Build-Tools 29.0.0

  • Android SDK Build-Tools 28.0.3

  • Android SDK Build-Tools 28.0.2

  • Android SDK Build-Tools 28.0.1

  • Android SDK Build-Tools 28.0.0

  • Android SDK Build-Tools 27.0.3

  • Android SDK Build-Tools 27.0.2

  • Android SDK Build-Tools 27.0.1

  • Android SDK Build-Tools 27.0.0

  • Android SDK Build-Tools 26.0.3

  • Android SDK Build-Tools 26.0.2

  • Android SDK Build-Tools 26.0.1

  • Android SDK Build-Tools 26.0.0

  • Android SDK Build-Tools 25.0.3

  • Android SDK Build-Tools 25.0.2

  • Android SDK Build-Tools 25.0.1

  • Android SDK Build-Tools 25.0.0

  • Android SDK Build-Tools 24.0.3

  • Android SDK Build-Tools 24.0.2

  • Android SDK Build-Tools 24.0.1

  • Android SDK Build-Tools 24.0.0

  • Android SDK Build-Tools 23.0.3

  • Android SDK Build-Tools 23.0.2

  • Android SDK Build-Tools 23.0.1

  • Android SDK Build-Tools 22.0.1

  • Android SDK Build-Tools 21.1.2

  • Android SDK Build-Tools 20.0.0

  • Android SDK Build-Tools 19.1.0

  • Android SDK Build-Tools 17.0.0

  • Android NDK 20.0.5594570

  • Android ConstraintLayout 1.0.2

  • Android ConstraintLayout 1.0.1

  • Az Module (1.0.0)

  • Az Module (1.6.0)

  • Az Module (2.3.2)

  • Az Module (2.6.0)

  • キャッシュされたコンテナイメージ

    • node:10 (Digest: sha256:dabc15ad36a9e0a95862fbdf6ffdad439edc20aa27c7f10456644464e3fb5f08)
    • node:10-alpine (Digest: sha256:b14a0f940b766176934efd14f5dc2f093f232e7292ab276b4aacf42606e2d3e1)
    • node:12 (Digest: sha256:fc6c1371e3a0883f17e34492bcaffb4d8ad986ebb4a5eeafa8817bd425446566)
    • node:12-alpine (Digest: sha256:e32343df0b80880915ca3570752cb41ac044253a5deec978f851b3834670fffa)
    • alpine:3.10 (Digest: sha256:c19173c5ada610a5989151111163d28a67368362762534d8a8121ce95cf2bd5a)
    • buildpack-deps:stretch (Digest: sha256:4c49708e49223a34ec243bc37e97896f767362bdc565fcabf21d7dd8f8511b43)
    • debian:9 (Digest: sha256:67344662277c1b24385859a31f71610a2bdda0e2492835542555f33c95a47dee)
    • debian:8 (Digest: sha256:e25703ee6ab5b2fac31510323d959cdae31eebdf48e88891c549e55b25ad7e94)
    • jekyll/builder:latest (Digest: sha256:875de39aa06300c749e26a79f39cdfa31404e4f2dbd2953cd4ebb0442bffda9e)
    • alpine:3.9 (Digest: sha256:7746df395af22f04212cd25a92c1d6dbc5a06a0ca9579a229ef43008d4d1302a)
    • alpine:3.7 (Digest: sha256:8421d9a84432575381bfabd248f1eb56f3aa21d9d7cd2511583c68c9b7511d10)
    • alpine:3.8 (Digest: sha256:04696b491e0cc3c58a75bace8941c14c924b9f313b03ce5029ebbc040ed9dcd9)
    • mcr.microsoft.com/azure-pipelines/node8-typescript:latest (Digest: sha256:e52e60b9f71183969830a3664279b5d8c799b4b0ec2c25a0686f7c02f6a9669a)
  • Python

    • Python 2.7.16
    • Python 3.4.10
    • Python 3.5.7
    • Python 3.6.9
    • Python 3.7.5
    • Python 3.8.0

    Note: These versions of Python are available through the setup-python action.

  • Ruby

    • Ruby 2.3.7
    • Ruby 2.4.6
    • Ruby 2.5.5
    • Ruby 2.6.3

    Note: These versions of Ruby are available through the setup-ruby action.

  • Python (Python 2.7.12)

  • pip (pip 8.1.1 from /usr/lib/python2.7/dist-packages (python 2.7))

  • Python3 (Python 3.5.2)

  • pip3 (pip 8.1.1 from /usr/lib/python3/dist-packages (python 3.5))

  • PyPy2 ([PyPy 7.1.0 with GCC 6.2.0 20160901])

  • PyPy3 ([PyPy 7.0.0 with GCC 6.2.0 20160901])

  • Boost C++ Libraries 1.69.0

Ubuntu 18.04 LTS

  • 7-Zip 16.02

  • Ansible (ansible 2.8.6)

  • AzCopy (azcopy 7.3.0-netcore)

  • Azure CLI (azure-cli 2.0.75)

  • Azure CLI (azure-devops 0.13.0)

  • Basic CLI:

    • curl
    • dnsutils
    • ファイル
    • ftp
    • iproute2
    • iputils-ping
    • jq
    • libcurl3
    • libicu55
    • libunwind8
    • locales
    • netcat
    • openssh-client
    • rsync
    • shellcheck
    • sudo
    • telnet
    • time
    • unzip
    • wget
    • zip
    • tzdata
  • AWS CLI (aws-cli/1.16.266 Python/2.7.15+ Linux/5.0.0-1022-azure botocore/1.13.2)

  • build-essential

  • Clang 6.0 (clang バージョン 6.0.1-svn334776-1~exp1~20190309042703.125 (branches/release_60))

  • CMake (cmake バージョン 3.12.4)

  • Docker Compose (docker-compose バージョン 1.22.0、ビルド f46880fe)

  • Docker (Docker バージョン 3.0.8, ビルド 2355349d)

  • .NET Core SDK:

    • 3.0.100
    • 2.2.402
    • 2.2.401
    • 2.2.301
    • 2.2.300
    • 2.2.206
    • 2.2.205
    • 2.2.204
    • 2.2.203
    • 2.2.202
    • 2.2.109
    • 2.2.108
    • 2.2.107
    • 2.2.106
    • 2.2.105
    • 2.2.104
    • 2.2.103
    • 2.2.102
    • 2.2.101
    • 2.2.100
    • 2.1.802
    • 2.1.801
    • 2.1.701
    • 2.1.700
    • 2.1.606
    • 2.1.605
    • 2.1.604
    • 2.1.603
    • 2.1.602
    • 2.1.509
    • 2.1.508
    • 2.1.507
    • 2.1.506
    • 2.1.505
    • 2.1.504
    • 2.1.503
    • 2.1.502
    • 2.1.500
    • 2.1.403
    • 2.1.402
    • 2.1.401
    • 2.1.302
    • 2.1.301
    • 2.1.300
  • Erlang (Erlang (SMP,ASYNC_THREADS,HIPE) (BEAM) エミュレーターバージョン 10.5.3)

  • Firefox (Mozilla Firefox 70.0)

  • GNU C++ 7.4.0

  • Git (2.23.0)

  • Git Large File Storage (LFS) (2.9.0)

  • Go 1.11 (go バージョン go1.11.12 linux/amd64)

  • Go 1.12 (go バージョン go1.12.7 linux/amd64)

  • Go 1.13 (go バージョン go1.13 linux/amd64)

  • Google Chrome (Google Chrome 78.0.3904.70 )

  • Google Cloud SDK (268.0.0)

  • Haskell Cabal (cabal-install バージョン 2.0.0.1 バージョン2.0.1.1の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 2.2.0.0 バージョン2.2.0.1の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 2.4.1.0 バージョン2.4.1.0の Cabalライブラリでコンパイル)

  • Haskell Cabal (cabal-install バージョン 3.0.0.0 バージョン3.0.0.0の Cabalライブラリでコンパイル)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.0.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.2.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.4.4)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.2)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.3)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.4)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.6.5)

  • GHC (The Glorious Glasgow Haskell Compilation System、バージョン 8.8.1)

  • Haskell Stack (バージョン 2.1.3, Git リビジョン 636e3a759d51127df2b62f90772def126cdf6d1f (7735 commits) x86_64 hpack-0.31.2)

  • Heroku (heroku/7.33.3 linux-x64 node-v11.14.0)

  • HHVM (HipHop VM 4.28.1 (rel))

  • ImageMagick

  • Azul Zulu OpenJDK (7) (openjdk バージョン "1.7.0_242")

  • Azul Zulu OpenJDK (8) (openjdk バージョン "1.8.0_232")

  • Azul Zulu OpenJDK (11) (openjdk バージョン "11.0.5" 2019-10-15 LTS)

  • Azul Zulu OpenJDK (12) (openjdk バージョン "12.0.2" 2019-07-16)

  • Ant (Apache Ant(TM) version 1.10.5、2019 年 3 月 28 日にコンパイル)

  • Gradle 5.6.3

  • Maven (Apache Maven 3.6.1 (d66c9c0b3152b2e69ee9bac180bb8fcc8e6af555; 2019-04-04T19:00:29Z))

  • Kind (v0.5.1)

  • kubectl (クライアントバージョン: v1.16.2)

  • helm (クライアント: v2.15.1+gcf1de4f)

  • Leiningen (Leiningen 2.9.1 on Java 1.8.0_232 OpenJDK 64-Bit Server VM)

  • Mercurial (Mercurial Distributed SCM (バージョン 4.5.3))

  • Miniconda (conda 4.7.12)

  • Mono (Mono JIT コンパイラバージョン 6.4.0.198 (tarball Tue Sep 24 01:21:28 UTC 2019))

  • MySQL (mysql Ver 14.14 Distrib 5.7.27, for Linux (x86_64) using EditLine wrapper)

  • MySQL Server (user:root password:root)

  • MS SQL Server Client Tools

  • Node.js (v12.13.0)

  • Bower (1.8.8)

  • Grunt (grunt-cli v1.2.0)

  • Gulp (CLI バージョン: 2.2.0 ローカルバージョン: 不明)

  • n (6.0.1)

  • Parcel (1.12.4)

  • TypeScript (バージョン 3.6.4)

  • Webpack (4.41.2)

  • Webpack CLI (3.3.9)

  • Yarn (1.19.1)

  • PhantomJS (2.1.1)

  • PHP 7.1 (PHP 7.1.32-2+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:43:48) ( NTS ))

  • PHP 7.2 (PHP 7.2.24-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:29:11) ( NTS ))

  • PHP 7.3 (PHP 7.3.11-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Oct 24 2019 18:23:23) ( NTS ))

  • Composer (Composer バージョン 1.9.0 2019-08-02 20:55:32)

  • PHPUnit (PHPUnit 7.5.16 by Sebastian Bergmann and contributors.)

  • Pollinate

  • Powershell (PowerShell 6.2.3)

  • rustup (1.20.2)

  • rust (1.38.0)

  • cargo (1.38.0)

  • rustfmt (1.4.4-stable)

  • clippy (0.0.212)

  • rustdoc (1.38.0)

  • bindgen (execute the 0.51.1)

  • cbindgen (0.9.1)

  • sbt (1.3.3)

  • Sphinx Open Source Search Server

  • Subversion (svn、バージョン 1.9.7 (r1800392))

  • Terraform (Terraform v0.12.12)

  • Vcpkg 2019.09.12-unknownhash

  • Zeit Now CLI (16.4.0)

  • Google Repository 58

  • Google Play services 49

  • Google APIs 24

  • Google APIs 23

  • Google APIs 22

  • Google APIs 21

  • CMake 3.6.4111459

  • Android Support Repository 47.0.0

  • Android SDK Platform-Tools 29.0.4

  • Android SDK Platform 29

  • Android SDK Platform 28

  • Android SDK Platform 27

  • Android SDK Platform 26

  • Android SDK Platform 25

  • Android SDK Platform 24

  • Android SDK Platform 23

  • Android SDK Platform 22

  • Android SDK Platform 21

  • Android SDK Platform 19

  • Android SDK Platform 17

  • Android SDK Patch Applier v4

  • Android SDK Build-Tools 29.0.2

  • Android SDK Build-Tools 29.0.0

  • Android SDK Build-Tools 28.0.3

  • Android SDK Build-Tools 28.0.2

  • Android SDK Build-Tools 28.0.1

  • Android SDK Build-Tools 28.0.0

  • Android SDK Build-Tools 27.0.3

  • Android SDK Build-Tools 27.0.2

  • Android SDK Build-Tools 27.0.1

  • Android SDK Build-Tools 27.0.0

  • Android SDK Build-Tools 26.0.3

  • Android SDK Build-Tools 26.0.2

  • Android SDK Build-Tools 26.0.1

  • Android SDK Build-Tools 26.0.0

  • Android SDK Build-Tools 25.0.3

  • Android SDK Build-Tools 25.0.2

  • Android SDK Build-Tools 25.0.1

  • Android SDK Build-Tools 25.0.0

  • Android SDK Build-Tools 24.0.3

  • Android SDK Build-Tools 24.0.2

  • Android SDK Build-Tools 24.0.1

  • Android SDK Build-Tools 24.0.0

  • Android SDK Build-Tools 23.0.3

  • Android SDK Build-Tools 23.0.2

  • Android SDK Build-Tools 23.0.1

  • Android SDK Build-Tools 22.0.1

  • Android SDK Build-Tools 21.1.2

  • Android SDK Build-Tools 20.0.0

  • Android SDK Build-Tools 19.1.0

  • Android SDK Build-Tools 17.0.0

  • Android NDK 20.0.5594570

  • Az Module (1.0.0)

  • Az Module (1.6.0)

  • Az Module (2.3.2)

  • Az Module (2.6.0)

  • キャッシュされたコンテナイメージ

    • node:10 (Digest: sha256:dabc15ad36a9e0a95862fbdf6ffdad439edc20aa27c7f10456644464e3fb5f08)
    • node:10-alpine (Digest: sha256:b14a0f940b766176934efd14f5dc2f093f232e7292ab276b4aacf42606e2d3e1)
    • node:12 (Digest: sha256:fc6c1371e3a0883f17e34492bcaffb4d8ad986ebb4a5eeafa8817bd425446566)
    • node:12-alpine (Digest: sha256:e32343df0b80880915ca3570752cb41ac044253a5deec978f851b3834670fffa)
    • alpine:3.10 (Digest: sha256:c19173c5ada610a5989151111163d28a67368362762534d8a8121ce95cf2bd5a)
    • buildpack-deps:stretch (Digest: sha256:4c49708e49223a34ec243bc37e97896f767362bdc565fcabf21d7dd8f8511b43)
    • debian:9 (Digest: sha256:67344662277c1b24385859a31f71610a2bdda0e2492835542555f33c95a47dee)
    • debian:8 (Digest: sha256:e25703ee6ab5b2fac31510323d959cdae31eebdf48e88891c549e55b25ad7e94)
    • jekyll/builder:latest (Digest: sha256:875de39aa06300c749e26a79f39cdfa31404e4f2dbd2953cd4ebb0442bffda9e)
    • alpine:3.9 (Digest: sha256:7746df395af22f04212cd25a92c1d6dbc5a06a0ca9579a229ef43008d4d1302a)
    • alpine:3.7 (Digest: sha256:8421d9a84432575381bfabd248f1eb56f3aa21d9d7cd2511583c68c9b7511d10)
    • alpine:3.8 (Digest: sha256:04696b491e0cc3c58a75bace8941c14c924b9f313b03ce5029ebbc040ed9dcd9)
    • mcr.microsoft.com/azure-pipelines/node8-typescript:latest (Digest: sha256:e52e60b9f71183969830a3664279b5d8c799b4b0ec2c25a0686f7c02f6a9669a)
  • Python

    • Python 2.7.16
    • Python 3.5.7
    • Python 3.6.9
    • Python 3.7.5
    • Python 3.8.0

    Note: These versions of Python are available through the setup-python action.

  • Ruby

    • Ruby 2.3.7
    • Ruby 2.4.6
    • Ruby 2.5.5
    • Ruby 2.6.3

    Note: These versions of Ruby are available through the setup-ruby action.

  • Python (Python 2.7.15+)

  • pip (pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7))

  • Python3 (Python 3.6.8)

  • pip3 (pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.6))

  • PyPy2 ([PyPy 7.1.0 with GCC 6.2.0 20160901])

  • PyPy3 ([PyPy 7.0.0 with GCC 6.2.0 20160901])

  • Boost C++ Libraries 1.69.0

Windows Server 2016

Note: The Windows Server 2016 virtual environment will be removed on December 3, 2019.

Chocolatey

バージョン: 0.10.15
環境:

  • PATH: choco.exe の場所を含む

Docker

バージョン: 19.03.4
環境:

  • PATH: docker.exe の場所を含む

Docker-compose

バージョン: 1.24.0
環境:

  • PATH: docker-compose.exe の場所を含む

Powershell Core

バージョン: 6.2.3

Docker イメージ

以下のコンテナイメージがキャッシュされています:

  • mcr.microsoft.com/dotnet/framework/aspnet:4.8-windowsservercore-ltsc2016 (Digest: sha256:f247ce2cdad4711b6a597bf3a84581278251e13176a2129158e3138fa7c6730d)
  • mcr.microsoft.com/dotnet/framework/runtime:4.8-windowsservercore-ltsc2016 (Digest: sha256:ebb0693431d47cbd070f8b6473b5a3b79896e8a146d202f78b92cabf6ceb4b3d)
  • mcr.microsoft.com/windows/servercore:ltsc2016 (Digest: sha256:45469202b1d2630e502330c0c4e977fac9b4540611c9778dedfc140f683f8f68)
  • microsoft/aspnetcore-build:1.0-2.0 (Digest: sha256:9ecc7c5a8a7a11dca5f08c860165646cb30d084606360a3a72b9cbe447241c0c)
  • mcr.microsoft.com/windows/nanoserver:10.0.14393.953 (Digest: sha256:fc60bd5ae0e61b334ce1cf1bcbf20c10c36b4c5482a01da319c9c989f9e6e268)

Visual Studio 2017 Enterprise

バージョン: VisualStudio/15.9.17+28307.905
場所: C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise

必須および推奨コンポーネントを含め、Visual Studio 2017 には以下のワークロードがインストールされています:

  • UWP 開発
  • .NET デスクトップ開発
  • C++ によるデスクトップ開発
  • ASP.NET と Web 開発
  • Azure
  • Node.js
  • データストレージとデータ処理
  • データサイエンスと分析のアプリケーション *
  • Unity によるゲーム開発 *
  • C++ による Linux 開発 *
  • C++ によるゲーム開発 *
  • C++ によるモバイル開発 *
  • Office/SharePoint
  • .NET によるモバイル開発
  • .NET Core クロスプラットフォームの開発
  • Visual Studio 拡張機能の開発 *
  • Python *
  • JavaScript によるモバイル開発 *

さらに、以下のオプションコンポーネントもインストールされています:

  • Microsoft.Net.Component.4.6.2.SDK
  • Microsoft.Net.Component.4.6.2.TargetingPack
  • Microsoft.Net.ComponentGroup.4.6.2.DeveloperTools
  • Microsoft.Net.Component.4.7.SDK
  • Microsoft.Net.Component.4.7.TargetingPack
  • Microsoft.Net.ComponentGroup.4.7.DeveloperTools
  • Microsoft.Net.Component.4.7.1.SDK
  • Microsoft.Net.Component.4.7.1.TargetingPack
  • Microsoft.Net.ComponentGroup.4.7.1.DeveloperTools
  • Microsoft.Net.ComponentGroup.4.7.2.DeveloperTools
  • Microsoft.Net.Core.Component.SDK.1x
  • Microsoft.NetCore.1x.ComponentGroup.Web
  • Microsoft.VisualStudio.Component.Azure.Storage.AzCopy
  • Microsoft.VisualStudio.Component.PowerShell.Tools
  • Microsoft.VisualStudio.Component.VC.140
  • Component.Dotfuscator
  • Microsoft.VisualStudio.Component.VC.ATL
  • Microsoft.VisualStudio.Component.VC.ATL.ARM
  • Microsoft.VisualStudio.Component.VC.ATL.ARM64
  • Microsoft.VisualStudio.Component.VC.ATLMFC
  • Microsoft.VisualStudio.Component.VC.ClangC2
  • Microsoft.VisualStudio.Component.VC.CLI.Support
  • Microsoft.VisualStudio.Component.VC.Modules.x86.x64
  • Microsoft.VisualStudio.Component.Windows10SDK.10240
  • Microsoft.VisualStudio.Component.Windows10SDK.10586
  • Microsoft.VisualStudio.Component.Windows10SDK.14393
  • Microsoft.VisualStudio.Component.Windows10SDK.15063.Desktop
  • Component.Unreal
  • Component.Unreal.Android
  • Component.Android.SDK23
  • Microsoft.VisualStudio.Component.TestTools.WebLoadTest
  • Microsoft.VisualStudio.Web.Mvc4.ComponentGroup
  • Component.Linux.CMake
  • Microsoft.Component.PythonTools.UWP
  • Microsoft.Component.VC.Runtime.OSSupport
  • Microsoft.VisualStudio.Component.VC.Tools.ARM
  • Microsoft.VisualStudio.ComponentGroup.UWP.VC
  • Microsoft.VisualStudio.Component.VSSDK
  • Microsoft.VisualStudio.Component.LinqToSql
  • Microsoft.VisualStudio.Component.TestTools.CodedUITest
  • Microsoft.VisualStudio.Component.TestTools.Core
  • Microsoft.VisualStudio.Component.TypeScript.2.0
  • Microsoft.VisualStudio.Component.TypeScript.2.1
  • Microsoft.VisualStudio.Component.TypeScript.2.2
  • Microsoft.VisualStudio.Component.VC.Tools.ARM64
  • Microsoft.VisualStudio.Component.Windows10SDK.16299.Desktop.arm
  • Microsoft.VisualStudio.Component.DslTools
  • Microsoft.VisualStudio.Component.Windows81SDK
  • Microsoft.VisualStudio.Component.WinXP
  • Microsoft.VisualStudio.ComponentGroup.NativeDesktop.Win81
  • Microsoft.VisualStudio.ComponentGroup.NativeDesktop.WinXP
  • Microsoft.VisualStudio.ComponentGroup.ArchitectureTools.Managed
  • Microsoft.Component.Blend.SDK.WPF
  • Microsoft.Component.VC.Runtime.UCRTSDK
  • Microsoft.VisualStudio.Component.VC.ATL.Spectre
  • Microsoft.VisualStudio.Component.VC.ATL.ARM.Spectre
  • Microsoft.VisualStudio.Component.VC.ATL.ARM64.Spectre
  • Microsoft.VisualStudio.Component.VC.ATLMFC.Spectre
  • Microsoft.VisualStudio.Component.Windows10SDK.17134
  • Microsoft.VisualStudio.Component.Windows10SDK.17763
  • Microsoft.VisualStudio.Component.VC.Runtimes.x86.x64.Spectre
  • Microsoft.VisualStudio.Component.VC.Runtimes.ARM.Spectre
  • Microsoft.VisualStudio.Component.VC.Runtimes.ARM64.Spectre

SQL Server Data Tools for VS 2017

バージョン: 15.1.61906.3130

以下のコンポーネントがインストールされています:

  • SQL Server Data Tools
  • SQL Server Analysis Services Designer
  • SQL Server Integration Services Designer
  • SQL Server Reporting Services Designers

WIX Tools

Toolset のバージョン: 3.11.4516
WIX Toolset Studio 2017 Extension のバージョン: 0.9.21.62588
環境:

  • WIX: WIX をインストールているルート

.NET 4.8

バージョン: 4.8.03761

Windows Driver Kit

バージョン: 10.0.17763.0

Azure Service Fabric

SDK バージョン: 3.3.617.9590
ランタイムバージョン: 6.4.617.9590

WinAppDriver

バージョン: 1.1.1809.18001

Android SDK Build Tools

29.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\29.0.2

29.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\29.0.0

28.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.3

28.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.2

28.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.1

28.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.0

27.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.3

27.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.2

27.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.1

27.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.0

26.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.3

26.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.2

26.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.1

26.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.0

25.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.3

25.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.2

25.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.1

25.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.0

24.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.3

24.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.2

24.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.1

24.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.0

23.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.3

23.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.2

23.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.1

22.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\22.0.1

21.1.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\21.1.2

20.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\20.0.0

19.1.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\19.1.0

Android SDK Platforms

10 (API 29)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-29

9 (API 28)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-28

8.1.0 (API 27)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-27

8.0.0 (API 26)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-26

7.1.1 (API 25)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-25

7.0 (API 24)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-24

6.0 (API 23)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-23

5.1.1 (API 22)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-22

5.0.1 (API 21)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-21

4.4.2 (API 19)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-19

Azure/AzureRM Powershell モジュール

2.1.0

このバージョンはインストールされており、"Get-Module -ListAvailable" で使用できます。

3.8.0

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_3.8.0\AzureRM\3.8.0\AzureRM.psd1

4.2.1

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_4.2.1\AzureRM\4.2.1\AzureRM.psd1

5.1.1

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_5.1.1\AzureRM\5.1.1\AzureRM.psd1

6.7.0

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_6.7.0\AzureRM\6.7.0\AzureRM.psd1

TLS12

バージョン: 1.2
説明: .NET はデフォルトで TLS 1.2 を利用するよう設定されています

Azure CLI

バージョン: 2.0.75 環境:

  • PATH: az.cmd の場所を含む

Azure DevOps CLI の拡張機能

バージョン: azure-devops 0.13.0

Python

バージョン: 2.7.16 (x64)
バージョン: 2.7.16 (x86)
バージョン:
3.4.4 (x64)
バージョン: 3.4.4 (x86)
バージョン:
3.5.4 (x64)
バージョン: 3.5.4 (x86)
バージョン:
3.6.8 (x64)
バージョン: 3.6.8 (x86)
バージョン:
3.7.5 (x64)
バージョン: 3.7.5 (x86)
バージョン:
3.8.0 (x64)
バージョン:_ 3.8.0 (x86)

Note: These versions of Python are available through the setup-python action.

PyPy

バージョン: 2.7.13 (x86)
バージョン: 3.5.3 (x86)

Note: These versions of Python are available through the setup-python action.

Ruby

バージョン: 2.4.6 (x64)
バージョン: 2.5.5 (x64)
バージョン: 2.6.3 (x64)

Note: These versions of Ruby are available through the setup-ruby action.

Python (64 bit)

Python 3.6.8

環境:

  • PATH: python.exe の場所を含む
Python 2.7.16

場所: C:/hostedtoolcache/windows/Python/2.7*/x64

Git

バージョン: 2.23.0
環境:

  • PATH: git.exe の場所を含む

Git Large File Storage (LFS)

バージョン: 2.8.0
環境:

  • PATH: git-lfs.exe の場所を含む
  • GIT_LFS_PATH: git-lfs.exe の場所

Go (x64)

1.9.7

環境:

  • GOROOT_1_9_X64: Go 1.9.7 をインストールしているルートディレクトリ
1.10.8

環境:

  • GOROOT_1_10_X64: Go 1.10.8 をインストールしているルートディレクトリ
1.11.12

環境:

  • GOROOT_1_11_X64: Go 1.11.12 をインストールしているルートディレクトリ
1.12.7

環境:

  • PATH: go.exe バージョン 1.12.7 の場所を含む
  • GOROOT: 1.12.7 をインストールしているルートディレクトリ
  • GOROOT_1_12_X64: Go 1.12.7 をインストールしているルートディレクトリ

    1.13

環境:

  • GOROOT_1_13_X64: Go 1.13 をインストールしているルートディレクトリ

Boost

  • PATH: Boost バージョンの場所を含む
  • BOOST_ROOT: Boost バージョンをインストールしているルートディレクトリ
  • BOOST_ROOT_1_69_0: Boost バージョンをインストールしているルートディレクトリ

PHP (x64)

7.3.11

環境:

  • PATH: php.exe バージョン 7.3.11 の場所を含む
  • PHPROOT: PHP 7.3.11 をインストールしているルートディレクトリ

Ruby (x64)

2.5.5p157

環境:

  • 場所: C:\hostedtoolcache\windows\Ruby\2.5.5\x64\bin
  • PATH: ruby.exe バージョン 2.5.5p157 の場所を含む

Rust (64-bit)

1.38.0

場所: C:\Rust.cargo\bin 環境:

  • PATH: rustc.exe の場所を含む

Subversion

バージョン: 1.8.17
環境:

  • PATH: svn.exe の場所を含む

Google Chrome

バージョン: 77.0.3865.120

Mozilla Firefox

バージョン: 69.0.3

Selenium Web Drivers

Chrome Driver

バージョン: 77.0.3865.40

環境:

  • ChromeWebDriver: chromedriver.exe の場所
Gecko Driver

バージョン: 0.24.0

環境:

  • GeckoWebDriver: geckodriver.exe の場所
IE Driver

バージョン: 3.8.0.0

環境:

  • IEWebDriver: IEDriverServer.exe の場所

Node.js

バージョン: 12.13.0
アーキテクチャ: x64
環境:

  • PATH: node.exe の場所を含む
  • Gulp CLI バージョン: 2.2.0 ローカルバージョン: 不明
  • Grunt grunt-cli v1.3.2
  • Bower 1.8.8
  • Yarn 1.19.1

npm

バージョン: 6.12.0
環境:

  • PATH: npm.cmd の場所を含む

Java Development Kit

1.8.0_222

環境:

  • JAVA_HOME: JDK の場所
  • PATH: JDK の bin フォルダを含む
1.7.0_232

場所: C:\Program Files\Java\zulu-7-azure-jdk_7.31.0.5-7.0.232-win_x64

11.0.4

場所: C:\Program Files\Java\zulu-11-azure-jdk_11.33.15-11.0.4-win_x64

Ant

バージョン: 1.10.5
環境:

  • PATH: ant.cmd の場所を含む
  • ANT_HOME: ant.cmd の場所
  • COBERTURA_HOME: cobertura-2.1.1.jar の場所

Maven

バージョン: 3.6.2
環境:

  • PATH: mvn.bat の場所を含む
  • M2_HOME: Maven をインストールしているルート

Gradle

バージョン: 5.6.2
環境:

  • PATH: gradle の場所を含む

Cmake

バージョン: 3.15.4
環境:

  • PATH: cmake.exe の場所を含む

SQL Server Data Tier Application Framework (x64)

バージョン: 15.0.4538.1

.NET Core

以下のランタイムおよび SDK がインストールされています:

環境:

  • PATH: dotnet.exe の場所を含む

SDK:

  • 3.0.100 C:\Program Files\dotnet\sdk\3.0.100
  • 2.2.402 C:\Program Files\dotnet\sdk\2.2.402
  • 2.2.401 C:\Program Files\dotnet\sdk\2.2.401
  • 2.2.301 C:\Program Files\dotnet\sdk\2.2.301
  • 2.2.300 C:\Program Files\dotnet\sdk\2.2.300
  • 2.2.206 C:\Program Files\dotnet\sdk\2.2.206
  • 2.2.205 C:\Program Files\dotnet\sdk\2.2.205
  • 2.2.204 C:\Program Files\dotnet\sdk\2.2.204
  • 2.2.203 C:\Program Files\dotnet\sdk\2.2.203
  • 2.2.202 C:\Program Files\dotnet\sdk\2.2.202
  • 2.2.109 C:\Program Files\dotnet\sdk\2.2.109
  • 2.2.108 C:\Program Files\dotnet\sdk\2.2.108
  • 2.2.107 C:\Program Files\dotnet\sdk\2.2.107
  • 2.2.106 C:\Program Files\dotnet\sdk\2.2.106
  • 2.2.105 C:\Program Files\dotnet\sdk\2.2.105
  • 2.2.104 C:\Program Files\dotnet\sdk\2.2.104
  • 2.2.103 C:\Program Files\dotnet\sdk\2.2.103
  • 2.2.102 C:\Program Files\dotnet\sdk\2.2.102
  • 2.2.101 C:\Program Files\dotnet\sdk\2.2.101
  • 2.2.100 C:\Program Files\dotnet\sdk\2.2.100
  • 2.1.802 C:\Program Files\dotnet\sdk\2.1.802
  • 2.1.801 C:\Program Files\dotnet\sdk\2.1.801
  • 2.1.701 C:\Program Files\dotnet\sdk\2.1.701
  • 2.1.700 C:\Program Files\dotnet\sdk\2.1.700
  • 2.1.606 C:\Program Files\dotnet\sdk\2.1.606
  • 2.1.605 C:\Program Files\dotnet\sdk\2.1.605
  • 2.1.604 C:\Program Files\dotnet\sdk\2.1.604
  • 2.1.603 C:\Program Files\dotnet\sdk\2.1.603
  • 2.1.602 C:\Program Files\dotnet\sdk\2.1.602
  • 2.1.509 C:\Program Files\dotnet\sdk\2.1.509
  • 2.1.508 C:\Program Files\dotnet\sdk\2.1.508
  • 2.1.507 C:\Program Files\dotnet\sdk\2.1.507
  • 2.1.506 C:\Program Files\dotnet\sdk\2.1.506
  • 2.1.505 C:\Program Files\dotnet\sdk\2.1.505
  • 2.1.504 C:\Program Files\dotnet\sdk\2.1.504
  • 2.1.503 C:\Program Files\dotnet\sdk\2.1.503
  • 2.1.502 C:\Program Files\dotnet\sdk\2.1.502
  • 2.1.500 C:\Program Files\dotnet\sdk\2.1.500
  • 2.1.403 C:\Program Files\dotnet\sdk\2.1.403
  • 2.1.402 C:\Program Files\dotnet\sdk\2.1.402
  • 2.1.401 C:\Program Files\dotnet\sdk\2.1.401
  • 2.1.302 C:\Program Files\dotnet\sdk\2.1.302
  • 2.1.301 C:\Program Files\dotnet\sdk\2.1.301
  • 2.1.300 C:\Program Files\dotnet\sdk\2.1.300
  • 2.1.202 C:\Program Files\dotnet\sdk\2.1.202
  • 1.1.14 C:\Program Files\dotnet\sdk\1.1.14

ランタイム:

  • 3.0.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\3.0.0
  • 2.2.7 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.7
  • 2.2.6 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.6
  • 2.2.5 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.5
  • 2.2.4 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.4
  • 2.2.3 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.3
  • 2.2.2 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.2
  • 2.2.1 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.1
  • 2.2.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.0
  • 2.1.9 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.9
  • 2.1.8 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.8
  • 2.1.7 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.7
  • 2.1.6 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.6
  • 2.1.5 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.5
  • 2.1.4 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.4
  • 2.1.3 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.3
  • 2.1.2 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.2
  • 2.1.13 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.13
  • 2.1.12 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.12
  • 2.1.11 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.11
  • 2.1.10 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.10
  • 2.1.1 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.1
  • 2.1.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.0
  • 2.0.9 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.0.9
  • 1.1.13 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\1.1.13
  • 1.0.16 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\1.0.16

Mysql

バージョン: 5.7.21.0
環境:

  • PATH: mysql.exe の場所を含む

SQLPS

バージョン: 1.0

SQLServer PS

バージョン: 21.1.18179

MinGW

バージョン: 8.1.0
環境:

  • PATH: MinGW 'bin' ディレクトリの場所を含む

TypeScript

バージョン: バージョン 3.6.4

Miniconda

バージョン: conda 4.6.14
環境:

  • CONDA: Miniconda をインストールしているルートの場所を含む

Azure CosmosDb Emulator

バージョン: 2.7.0.0
場所: C:\Program Files\Azure Cosmos DB Emulator\

7zip

バージョン: 19.00

Mercurial

バージョン:

jq

バージョン: jq-1.6

Inno Setup

バージョン: 6.0.3

Perl

バージョン: v5.26.2

GitVersion

バージョン: 5.1.1.0

OpenSSL

バージョン: 1.1.1c 場所: C:\Program Files\Git\usr\bin\openssl.exe
バージョン: 1.1.1c 場所: C:\Program Files\Git\mingw64\bin\openssl.exe
バージョン: 1.0.2j 場所: C:\Program Files (x86)\Subversion\bin\openssl.exe
バージョン: 1.1.1b 場所: C:\Strawberry\c\bin\openssl.exe
バージョン: 1.1.1 場所: C:\Program Files\OpenSSL\bin\openssl.exe

Cloud Foundry CLI

バージョン: 6.47.1

Vcpkg

バージョン: 2019.09.12-nohash
環境:

  • PATH: vcpkg ディレクトリの場所を含む
  • VCPKG_INSTALLATION_ROOT: vcpkg をインストールしているルートディレクトリ

Kubectl

バージョン: クライアントバージョン: v1.16.2
環境:

  • PATH: kubectl.exe の場所を含む

Kind

バージョン: v0.5.1
環境:

  • PATH: kind.exe の場所を含む

Windows Server 2019

Chocolatey

バージョン: 0.10.15
環境:

  • PATH: choco.exe の場所を含む

Docker

バージョン: 19.03.4
環境:

  • PATH: docker.exe の場所を含む

Docker-compose

バージョン: 1.24.0
環境:

  • PATH: docker-compose.exe の場所を含む

Powershell Core

バージョン: 6.2.3

Docker イメージ

以下のコンテナイメージがキャッシュされています:

  • mcr.microsoft.com/dotnet/framework/aspnet:4.8-windowsservercore-ltsc2019 (Digest: sha256:e0f80fbc8bb2f39bd0eaba78b314444863ca3efec3f0e40a1b63aa501a36ef01)
  • mcr.microsoft.com/dotnet/framework/runtime:4.8-windowsservercore-ltsc2019 (Digest: sha256:c7219ea532e525bc34402027f7974a128746ebec79a31462bc8b59a9dfa6b3d8)
  • mcr.microsoft.com/windows/servercore:ltsc2019 (Digest: sha256:404e0ee336a063619d1e93a2446061cf19cb3068bacb1775f5613e3b54e527e1)
  • mcr.microsoft.com/windows/nanoserver:1809 (Digest: sha256:da46159cc4409ccdfe8e25d1e2b2e2705c31d956122d39ea89733b19d76340dd)
  • microsoft/aspnetcore-build:1.0-2.0 (Digest: sha256:9ecc7c5a8a7a11dca5f08c860165646cb30d084606360a3a72b9cbe447241c0c)

Visual Studio 2019 Enterprise

バージョン: VisualStudio/16.3.6+29418.71
場所: C:\Program Files (x86)\Microsoft Visual Studio\2019\Enterprise

Visual Studio 2019 には以下のワークロードおよびコンポーネントがインストールされています:

  • Component.Dotfuscator
  • Component.Linux.CMake
  • Component.UnityEngine.x64
  • Component.UnityEngine.x86
  • Component.Unreal.Android
  • Microsoft.Component.Azure.DataLake.Tools
  • Microsoft.Component.CookiecutterTools
  • Microsoft.Component.PythonTools.Miniconda
  • Microsoft.Component.PythonTools.Web
  • Microsoft.Component.VC.Runtime.UCRTSDK
  • Microsoft.Net.ComponentGroup.4.6.2.DeveloperTools
  • Microsoft.Net.ComponentGroup.4.7.1.DeveloperTools
  • Microsoft.Net.ComponentGroup.4.7.DeveloperTools
  • Microsoft.VisualStudio.Component.AspNet45
  • Microsoft.VisualStudio.Component.Azure.Kubernetes.Tools
  • Microsoft.VisualStudio.Component.Azure.MobileAppsSdk
  • Microsoft.VisualStudio.Component.Azure.ServiceFabric.Tools
  • Microsoft.VisualStudio.Component.Azure.Storage.AzCopy
  • Microsoft.VisualStudio.Component.Debugger.JustInTime
  • Microsoft.VisualStudio.Component.DslTools
  • Microsoft.VisualStudio.Component.EntityFramework
  • Microsoft.VisualStudio.Component.FSharp.Desktop
  • Microsoft.VisualStudio.Component.LinqToSql
  • Microsoft.VisualStudio.Component.PortableLibrary
  • Microsoft.VisualStudio.Component.TeamOffice
  • Microsoft.VisualStudio.Component.TestTools.CodedUITest
  • Microsoft.VisualStudio.Component.TestTools.WebLoadTest
  • Microsoft.VisualStudio.Component.UWP.VC.ARM64
  • Microsoft.VisualStudio.Component.VC.ATL.ARM
  • Microsoft.VisualStudio.Component.VC.ATLMFC
  • Microsoft.VisualStudio.Component.VC.ATLMFC.Spectre
  • Microsoft.VisualStudio.Component.VC.CLI.Support
  • Microsoft.VisualStudio.Component.VC.CMake.Project
  • Microsoft.VisualStudio.Component.VC.DiagnosticTools
  • Microsoft.VisualStudio.Component.VC.Llvm.ClangToolset
  • Microsoft.VisualStudio.Component.VC.MFC.ARM
  • Microsoft.VisualStudio.Component.VC.MFC.ARM.Spectre
  • Microsoft.VisualStudio.Component.VC.MFC.ARM64
  • Microsoft.VisualStudio.Component.VC.MFC.ARM64.Spectre
  • Microsoft.VisualStudio.Component.VC.Runtimes.ARM.Spectre
  • Microsoft.VisualStudio.Component.VC.Runtimes.ARM64.Spectre
  • Microsoft.VisualStudio.Component.VC.Runtimes.x86.x64.Spectre
  • Microsoft.VisualStudio.Component.VC.TestAdapterForBoostTest
  • Microsoft.VisualStudio.Component.VC.TestAdapterForGoogleTest
  • Microsoft.VisualStudio.Component.VC.v141
  • Microsoft.VisualStudio.Component.Windows10SDK.16299
  • Microsoft.VisualStudio.Component.Windows10SDK.17134
  • Microsoft.VisualStudio.Component.Windows10SDK.17763
  • Microsoft.VisualStudio.Component.Windows10SDK.18362
  • Microsoft.VisualStudio.ComponentGroup.Azure.CloudServices
  • Microsoft.VisualStudio.ComponentGroup.Azure.ResourceManager.Tools
  • Microsoft.VisualStudio.ComponentGroup.NativeDesktop.Llvm.Clang
  • Microsoft.VisualStudio.ComponentGroup.Web.CloudTools
  • Microsoft.VisualStudio.Workload.Azure
  • Microsoft.VisualStudio.Workload.Data
  • Microsoft.VisualStudio.Workload.DataScience
  • Microsoft.VisualStudio.Workload.ManagedDesktop
  • Microsoft.VisualStudio.Workload.ManagedGame
  • Microsoft.VisualStudio.Workload.NativeCrossPlat
  • Microsoft.VisualStudio.Workload.NativeDesktop
  • Microsoft.VisualStudio.Workload.NativeGame
  • Microsoft.VisualStudio.Workload.NativeMobile
  • Microsoft.VisualStudio.Workload.NetCoreTools
  • Microsoft.VisualStudio.Workload.NetCrossPlat
  • Microsoft.VisualStudio.Workload.NetWeb
  • Microsoft.VisualStudio.Workload.Node
  • Microsoft.VisualStudio.Workload.Office
  • Microsoft.VisualStudio.Workload.Python
  • Microsoft.VisualStudio.Workload.Universal
  • Microsoft.VisualStudio.Workload.VisualStudioExtension

WIX Tools

Toolset のバージョン: 3.11.4516
WIX Toolset Visual Studio Extension のバージョン: 1.0.0.4
環境:

  • WIX: WIX をインストールているルート

.NET 4.8

バージョン: 4.8.03761

Windows Driver Kit

バージョン: 10.0.17763.0

Azure Service Fabric

SDK バージョン: 3.3.617.9590
ランタイムバージョン: 6.4.617.9590

WinAppDriver

バージョン: 1.1.1809.18001

Android SDK Build Tools

29.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\29.0.2

29.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\29.0.0

28.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.3

28.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.2

28.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.1

28.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\28.0.0

27.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.3

27.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.2

27.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.1

27.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\27.0.0

26.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.3

26.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.2

26.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.1

26.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\26.0.0

25.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.3

25.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.2

25.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.1

25.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\25.0.0

24.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.3

24.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.2

24.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.1

24.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\24.0.0

23.0.3

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.3

23.0.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.2

23.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\23.0.1

22.0.1

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\22.0.1

21.1.2

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\21.1.2

20.0.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\20.0.0

19.1.0

場所: C:\Program Files (x86)\Android\android-sdk\build-tools\19.1.0

Android SDK Platforms

10 (API 29)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-29

9 (API 28)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-28

8.1.0 (API 27)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-27

8.0.0 (API 26)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-26

7.1.1 (API 25)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-25

7.0 (API 24)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-24

6.0 (API 23)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-23

5.1.1 (API 22)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-22

5.0.1 (API 21)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-21

4.4.2 (API 19)

場所: C:\Program Files (x86)\Android\android-sdk\platforms\android-19

Azure/AzureRM Powershell モジュール

2.1.0

このバージョンはインストールされており、"Get-Module -ListAvailable" で使用できます。

3.8.0

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_3.8.0\AzureRM\3.8.0\AzureRM.psd1

4.2.1

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_4.2.1\AzureRM\4.2.1\AzureRM.psd1

5.1.1

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_5.1.1\AzureRM\5.1.1\AzureRM.psd1

6.7.0

このバージョンは保存されていますが、インストールはされていません。 場所: C:\Modules\azurerm_6.7.0\AzureRM\6.7.0\AzureRM.psd1

TLS12

バージョン: 1.2
説明: .NET はデフォルトで TLS 1.2 を利用するよう設定されています

Azure CLI

バージョン: 2.0.75 環境:

  • PATH: az.cmd の場所を含む

Azure DevOps CLI の拡張機能

バージョン: azure-devops 0.13.0

Python

バージョン: 2.7.16 (x64)
バージョン: 2.7.16 (x86)
バージョン:
3.4.4 (x64)
バージョン: 3.4.4 (x86)
バージョン:
3.5.4 (x64)
バージョン: 3.5.4 (x86)
バージョン:
3.6.8 (x64)
バージョン: 3.6.8 (x86)
バージョン:
3.7.5 (x64)
バージョン: 3.7.5 (x86)
バージョン:
3.8.0 (x64)
バージョン:_ 3.8.0 (x86)

Note: These versions of Python are available through the setup-python action.

PyPy

バージョン: 2.7.13 (x86)
バージョン: 3.5.3 (x86)

Note: These versions of Python are available through the setup-python action.

Ruby

バージョン: 2.4.6 (x64)
バージョン: 2.5.5 (x64)
バージョン: 2.6.3 (x64)

Note: These versions of Ruby are available through the setup-ruby action.

Python (64 bit)

Python 3.7.5

環境:

  • PATH: python.exe の場所を含む
Python 2.7.16

場所: C:/hostedtoolcache/windows/Python/2.7*/x64

Git

バージョン: 2.23.0
環境:

  • PATH: git.exe の場所を含む

Git Large File Storage (LFS)

バージョン: 2.8.0
環境:

  • PATH: git-lfs.exe の場所を含む
  • GIT_LFS_PATH: git-lfs.exe の場所

Go (x64)

1.10.8

環境:

  • GOROOT_1_10_X64: Go 1.10.8 をインストールしているルートディレクトリ
1.11.12

環境:

  • GOROOT_1_11_X64: Go 1.11.12 をインストールしているルートディレクトリ
1.12.7

環境:

  • PATH: go.exe バージョン 1.12.7 の場所を含む
  • GOROOT: 1.12.7 をインストールしているルートディレクトリ
  • GOROOT_1_12_X64: Go 1.12.7 をインストールしているルートディレクトリ

    1.13

環境:

  • GOROOT_1_13_X64: Go 1.13 をインストールしているルートディレクトリ

Boost

  • PATH: Boost バージョンの場所を含む
  • BOOST_ROOT: Boost バージョンをインストールしているルートディレクトリ
  • BOOST_ROOT_1_69_0: Boost バージョンをインストールしているルートディレクトリ

PHP (x64)

7.3.11

環境:

  • PATH: php.exe バージョン 7.3.11 の場所を含む
  • PHPROOT: PHP 7.3.11 をインストールしているルートディレクトリ

Ruby (x64)

2.5.5p157

環境:

  • 場所: C:\hostedtoolcache\windows\Ruby\2.5.5\x64\bin
  • PATH: ruby.exe バージョン 2.5.5p157 の場所を含む

Rust (64-bit)

1.38.0

場所: C:\Rust.cargo\bin 環境:

  • PATH: rustc.exe の場所を含む

Subversion

バージョン: 1.8.17
環境:

  • PATH: svn.exe の場所を含む

Google Chrome

バージョン: 77.0.3865.120

Mozilla Firefox

バージョン: 69.0.3

Selenium Web Drivers

Chrome Driver

バージョン: 77.0.3865.40

環境:

  • ChromeWebDriver: chromedriver.exe の場所
Gecko Driver

バージョン: 0.24.0

環境:

  • GeckoWebDriver: geckodriver.exe の場所
IE Driver

バージョン: 3.8.0.0

環境:

  • IEWebDriver: IEDriverServer.exe の場所

Node.js

バージョン: 12.13.0
アーキテクチャ: x64
環境:

  • PATH: node.exe の場所を含む
  • Gulp CLI バージョン: 2.2.0 ローカルバージョン: 不明
  • Grunt grunt-cli v1.3.2
  • Bower 1.8.8
  • Yarn 1.19.1

npm

バージョン: 6.12.0
環境:

  • PATH: npm.cmd の場所を含む

Java Development Kit

1.8.0_222

環境:

  • JAVA_HOME: JDK の場所
  • PATH: JDK の bin フォルダを含む
1.7.0_232

場所: C:\Program Files\Java\zulu-7-azure-jdk_7.31.0.5-7.0.232-win_x64

11.0.4

場所: C:\Program Files\Java\zulu-11-azure-jdk_11.33.15-11.0.4-win_x64

Ant

バージョン: 1.10.5
環境:

  • PATH: ant.cmd の場所を含む
  • ANT_HOME: ant.cmd の場所
  • COBERTURA_HOME: cobertura-2.1.1.jar の場所

Maven

バージョン: 3.6.2
環境:

  • PATH: mvn.bat の場所を含む
  • M2_HOME: Maven をインストールしているルート

Gradle

バージョン: 5.6.2
環境:

  • PATH: gradle の場所を含む

Cmake

バージョン: 3.15.4
環境:

  • PATH: cmake.exe の場所を含む

SQL Server Data Tier Application Framework (x64)

バージョン: 15.0.4538.1

.NET Core

以下のランタイムおよび SDK がインストールされています:

環境:

  • PATH: dotnet.exe の場所を含む

SDK:

  • 3.0.100 C:\Program Files\dotnet\sdk\3.0.100
  • 2.2.402 C:\Program Files\dotnet\sdk\2.2.402
  • 2.2.401 C:\Program Files\dotnet\sdk\2.2.401
  • 2.2.301 C:\Program Files\dotnet\sdk\2.2.301
  • 2.2.300 C:\Program Files\dotnet\sdk\2.2.300
  • 2.2.206 C:\Program Files\dotnet\sdk\2.2.206
  • 2.2.205 C:\Program Files\dotnet\sdk\2.2.205
  • 2.2.204 C:\Program Files\dotnet\sdk\2.2.204
  • 2.2.203 C:\Program Files\dotnet\sdk\2.2.203
  • 2.2.202 C:\Program Files\dotnet\sdk\2.2.202
  • 2.2.109 C:\Program Files\dotnet\sdk\2.2.109
  • 2.2.108 C:\Program Files\dotnet\sdk\2.2.108
  • 2.2.107 C:\Program Files\dotnet\sdk\2.2.107
  • 2.2.106 C:\Program Files\dotnet\sdk\2.2.106
  • 2.2.105 C:\Program Files\dotnet\sdk\2.2.105
  • 2.2.104 C:\Program Files\dotnet\sdk\2.2.104
  • 2.2.103 C:\Program Files\dotnet\sdk\2.2.103
  • 2.2.102 C:\Program Files\dotnet\sdk\2.2.102
  • 2.2.101 C:\Program Files\dotnet\sdk\2.2.101
  • 2.2.100 C:\Program Files\dotnet\sdk\2.2.100
  • 2.1.802 C:\Program Files\dotnet\sdk\2.1.802
  • 2.1.801 C:\Program Files\dotnet\sdk\2.1.801
  • 2.1.701 C:\Program Files\dotnet\sdk\2.1.701
  • 2.1.700 C:\Program Files\dotnet\sdk\2.1.700
  • 2.1.606 C:\Program Files\dotnet\sdk\2.1.606
  • 2.1.605 C:\Program Files\dotnet\sdk\2.1.605
  • 2.1.604 C:\Program Files\dotnet\sdk\2.1.604
  • 2.1.603 C:\Program Files\dotnet\sdk\2.1.603
  • 2.1.602 C:\Program Files\dotnet\sdk\2.1.602
  • 2.1.509 C:\Program Files\dotnet\sdk\2.1.509
  • 2.1.508 C:\Program Files\dotnet\sdk\2.1.508
  • 2.1.507 C:\Program Files\dotnet\sdk\2.1.507
  • 2.1.506 C:\Program Files\dotnet\sdk\2.1.506
  • 2.1.505 C:\Program Files\dotnet\sdk\2.1.505
  • 2.1.504 C:\Program Files\dotnet\sdk\2.1.504
  • 2.1.503 C:\Program Files\dotnet\sdk\2.1.503
  • 2.1.502 C:\Program Files\dotnet\sdk\2.1.502
  • 2.1.500 C:\Program Files\dotnet\sdk\2.1.500
  • 2.1.403 C:\Program Files\dotnet\sdk\2.1.403
  • 2.1.402 C:\Program Files\dotnet\sdk\2.1.402
  • 2.1.401 C:\Program Files\dotnet\sdk\2.1.401
  • 2.1.302 C:\Program Files\dotnet\sdk\2.1.302
  • 2.1.301 C:\Program Files\dotnet\sdk\2.1.301
  • 2.1.300 C:\Program Files\dotnet\sdk\2.1.300

ランタイム:

  • 3.0.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\3.0.0
  • 2.2.7 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.7
  • 2.2.6 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.6
  • 2.2.5 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.5
  • 2.2.4 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.4
  • 2.2.3 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.3
  • 2.2.2 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.2
  • 2.2.1 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.1
  • 2.2.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.2.0
  • 2.1.9 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.9
  • 2.1.8 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.8
  • 2.1.7 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.7
  • 2.1.6 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.6
  • 2.1.5 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.5
  • 2.1.4 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.4
  • 2.1.3 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.3
  • 2.1.2 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.2
  • 2.1.13 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.13
  • 2.1.12 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.12
  • 2.1.11 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.11
  • 2.1.10 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.10
  • 2.1.1 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.1
  • 2.1.0 C:\Program Files\dotnet\shared\Microsoft.NETCore.App\2.1.0

Mysql

バージョン: 5.7.21.0
環境:

  • PATH: mysql.exe の場所を含む

MinGW

バージョン: 8.1.0
環境:

  • PATH: MinGW 'bin' ディレクトリの場所を含む

TypeScript

バージョン: バージョン 3.6.4

Miniconda

バージョン: conda 4.6.14
環境:

  • CONDA: Miniconda をインストールしているルートの場所を含む

Azure CosmosDb Emulator

バージョン: 2.7.0.0
場所: C:\Program Files\Azure Cosmos DB Emulator\

7zip

バージョン: 19.00

Mercurial

バージョン:

jq

バージョン: jq-1.6

Inno Setup

バージョン: 6.0.3

Perl

バージョン: v5.26.2

GitVersion

バージョン: 5.1.1.0

OpenSSL

バージョン: 1.1.1c 場所: C:\Program Files\Git\usr\bin\openssl.exe
バージョン: 1.1.1c 場所: C:\Program Files\Git\mingw64\bin\openssl.exe
バージョン: 1.0.2j 場所: C:\Program Files (x86)\Subversion\bin\openssl.exe
バージョン: 1.1.1b 場所: C:\Strawberry\c\bin\openssl.exe
バージョン: 1.1.1 場所: C:\Program Files\OpenSSL\bin\openssl.exe

Cloud Foundry CLI

バージョン: 6.47.1

Vcpkg

バージョン: 2019.09.12-nohash
環境:

  • PATH: vcpkg ディレクトリの場所を含む
  • VCPKG_INSTALLATION_ROOT: vcpkg をインストールしているルートディレクトリ

Kubectl

バージョン: クライアントバージョン: v1.16.2
環境:

  • PATH: kubectl.exe の場所を含む

Kind

バージョン: v0.5.1
環境:

  • PATH: kind.exe の場所を含む

macOS 10.15

Xcode 11.1 がデフォルトで設定されています

オペレーティングシステム

  • OS X 10.15.1 (19B88) Catalina

インストールされているソフトウェア

言語およびランタイム
  • java 1.7 : OpenJDK Runtime Environment (Zulu 7.34.0.5-CA-macosx) (ビルド 1.7.0_242-b7)
  • java 1.8 : OpenJDK Runtime Environment (Zulu 8.42.0.21-CA-macosx) (ビルド 1.8.0_232-b18) (デフォルト)
  • java 11 : OpenJDK Runtime Environment Zulu11.35+13-CA (ビルド 11.0.5+10-LTS)
  • java 12 : OpenJDK Runtime Environment Zulu12.3+11-CA (ビルド 12.0.2+3)
  • java 13 : OpenJDK Runtime Environment Zulu13.28+11-CA (ビルド 13.0.1+10-MTS)
  • Node.js 12.12.0
  • NVM 0.33.11
  • NVM - インストールされているノードのバージョン: v6.17.1 v8.16.2 v10.17.0 v12.12.0
  • PowerShell 6.2.3
  • Python 2.7.17
  • Python 3.7.5
  • Ruby 2.6.5p114
  • .NET Core SDK 2.0.0 3.0.100
  • Go 1.13.4
Python
  • 2.7.16
  • 3.5.7
  • 3.6.9
  • 3.7.5
  • 3.8.
  • pypy2
  • pypy3

Note: These versions of Python are available through the setup-python action.

Ruby
  • 2.4.6
  • 2.5.5
  • 2.6.3

Note: These versions of Ruby are available through the setup-ruby action.

パッケージ管理
  • Bundler 2.0.2
  • Carthage 0.33.0
  • CocoaPods 1.8.3
  • Homebrew 2.1.13
  • NPM 3.10.10
  • Yarn 1.19.1
  • NuGet 4.7.0.5148
  • pip 19.1.1(python 2.7)
  • pip 19.2.3(python 3.7)
  • Miniconda 4.7.10
プロジェクト管理
  • Apache Maven 3.6.2
  • Gradle 5.6.2
ユーティリティ
  • curl 7.66.0 (libcurl/7.66.0 SecureTransport zlib/1.2.11)
  • Git 2.23.0
  • Git LFS 2.8.0
  • GNU Wget 1.20.3
  • Subversion (SVN) 1.12.2
  • GNU parallel 20190922
ツール
  • fastlane 2.133.0
  • App Center CLI 1.2.2
  • Azure-CLI 2.0.74
Xcode
バージョン ビルド パス
11.2_beta 2 11B44 /Applications/Xcode_11.2.app
11.1 11A1027 /Applications/Xcode_11.1.app
11.0 11A420a /Applications/Xcode_11.app
Xcode サポートツール
  • Nomad CLI 3.0.6
  • Nomad CLI IPA 0.14.3
  • xcpretty 0.3.0
  • xctool 0.3.6
  • xcversion 2.6.1
インストールされている SDK
SDK SDK 名 Xcode のバージョン
macOS 10.15 macosx10.15 11.0, 11.1, 11.2_beta 2
iOS 13.0 iphoneos13.0 11.0
iOS 13.1 iphoneos13.1 11.1
iOS 13.2 iphoneos13.2 11.2_beta 2
iOS Simulator 13.0 iphonesimulator13.0 11.0
iOS Simulator 13.1 iphonesimulator13.1 11.1
iOS Simulator 13.2 iphonesimulator13.2 11.2_beta 2
tvOS 13.0 appletvos13.0 11.0、11.1
tvOS 13.2 appletvos13.2 11.2_beta 2
tvOS Simulator 13.0 appletvsimulator13.0 11.0、11.1
tvOS Simulator 13.2 appletvsimulator13.2 11.2_beta 2
watchOS 6.0 watchos6.0 11.0、11.1
watchOS 6.1 watchos6.1 11.2_beta 2
watchOS Simulator 6.0 watchsimulator6.0 11.0、11.1
watchOS Simulator 6.1 watchsimulator6.1 11.2_beta 2
DriverKit 19.0 driverkit.macosx19.0 11.0, 11.1, 11.2_beta 2
インストールされているシミュレーター
ランタイム
OS Xcode のバージョン シミュレーター
iOS 13.0 (17A577a) 11 iPhone 8
iPhone 8 Plus
iPhone 11
iPhone 11 Pro
iPhone 11 Pro Max
iPad Pro (9.7-inch)
iPad Pro
iPad Pro (12.9 インチ) (第 3 世代)
iPad Air (第 3 世代)







iOS 13.1 (17A844) 11.1 iPhone 8
iPhone 8 Plus
iPhone 11
iPhone 11 Pro
iPhone 11 Pro Max
iPad Pro (9.7-inch)
iPad Pro
iPad Pro (12.9 インチ) (第 3 世代)
iPad Air (第 3 世代)







iOS 13.2 (17B5068e) 11.2_beta 2 iPhone 8
iPhone 8 Plus
iPhone 11
iPhone 11 Pro
iPhone 11 Pro Max
iPad Pro (9.7-inch)
iPad Pro
iPad Pro (12.9 インチ) (第 3 世代)
iPad Air (第 3 世代)







tvOS 13.0 (17J559)
tvOS 13.2 (17K5068b)
11.0
11.1
Apple TV
Apple TV 4K
Apple TV 4K (1080p 表示)

watchOS 6.0 (17R566)

watchOS 6.1 (17S5068e)

11.0
11.1
11.2_beta 2

Apple Watch Series 4 40mm
Apple Watch Series 4 44mm
Apple Watch Series 5 40mm
Apple Watch Series 5 44mm


Note: Only default simulators for each Xcode version are installed. 一部のシミュレーターをインストールすると、互換性の問題を起こすことがあります。 特定のシミュレーターをインストールするには、xcversion ツールを使います。

xcversion simulators --install='iOS 13.0'
デバイスのペア
Watch Phone
Apple Watch - 38mm iPhone 6s
Apple Watch - 42mm iPhone 6s Plus
Apple Watch Series 2 - 38mm iPhone 7
Apple Watch Series 2 - 42mm iPhone 7 Plus
Apple Watch Series 3 - 38mm iPhone 8
Apple Watch Series 3 - 42mm iPhone 8 Plus
Apple Watch Series 4 - 40mm iPhone XS
Apple Watch Series 4 - 44mm iPhone XS Max
Apple Watch Series 5 - 40mm iPhone 11 Pro
Apple Watch Series 5 - 44mm iPhone 11 Pro Max

Android

Android SDK Tools
パッケージ名 説明
ツール Android SDK Tools, revision 26.1.1
Android SDK Platform-tools
パッケージ名 説明
プラットフォームツール Android SDK Platform-tools, revision 29.0.4
Android SDK Platforms
パッケージ名 説明
android-15 Android SDK Platform 15, Revision 5
android-16 Android SDK Platform 16, Revision 5
android-17 Android SDK Platform 17, Revision 3
android-18 Android SDK Platform 18, Revision 3
android-19 Android SDK Platform 19, Revision 4
android-20 Android SDK Platform 20, Revision 2
android-21 Android SDK Platform 21, Revision 2
android-22 Android SDK Platform 22, Revision 2
android-23 Android SDK Platform 23, Revision 3
android-24 Android SDK Platform 24, Revision 2
android-25 Android SDK Platform 25, Revision 3
android-26 Android SDK Platform 26, Revision 2
android-27 Android SDK Platform 27, Revision 3
android-28 Android SDK Platform 28, Revision 6
android-29 Android SDK Platform 29, Revision 3
Android SDK Build-tools
パッケージ名 説明
build-tools-24.0.0 Android SDK Build-tools, Revision 24.0.0
build-tools-24.0.1 Android SDK Build-tools, Revision 24.0.1
build-tools-24.0.2 Android SDK Build-tools, Revision 24.0.2
build-tools-24.0.3 Android SDK Build-tools, Revision 24.0.3
build-tools-25.0.0 Android SDK Build-tools, Revision 25.0.0
build-tools-25.0.1 Android SDK Build-tools, Revision 25.0.1
build-tools-25.0.2 Android SDK Build-tools, Revision 25.0.2
build-tools-25.0.3 Android SDK Build-tools, Revision 25.0.3
build-tools-26.0.0 Android SDK Build-tools, Revision 26.0.0
build-tools-26.0.1 Android SDK Build-tools, Revision 26.0.1
build-tools-26.0.2 Android SDK Build-tools, Revision 26.0.2
build-tools-26.0.3 Android SDK Build-tools, Revision 26.0.3
build-tools-27.0.0 Android SDK Build-tools, Revision 27.0.0
build-tools-27.0.1 Android SDK Build-tools, Revision 27.0.1
build-tools-27.0.2 Android SDK Build-tools, Revision 27.0.2
build-tools-27.0.3 Android SDK Build-tools, Revision 27.0.3
build-tools-28.0.0 Android SDK Build-tools, Revision 28.0.0
build-tools-28.0.1 Android SDK Build-tools, Revision 28.0.1
build-tools-28.0.2 Android SDK Build-tools, Revision 28.0.2
build-tools-28.0.3 Android SDK Build-tools, Revision 28.0.3
build-tools-29.0.0 Android SDK Build-tools, Revision 29.0.0
build-tools-29.0.1 Android SDK Build-tools, Revision 29.0.1
build-tools-29.0.2 Android SDK Build-tools, Revision 29.0.2
ユーティリティ
パッケージ名 説明
cmake 3.6.4111459
lldb 2.3.3614996
ndk-bundle 18.1.5063045
ProGuard 5.3.3
Android Emulator 29.2.1
Google APIs
パッケージ名 説明
google_apis-google-21 Google APIs, Android API 21, revision 1
google_apis-google-22 Google APIs, Android API 22, revision 1
google_apis-google-23 Google APIs, Android API 23, revision 1
google_apis-google-24 Google APIs, Android API 24, revision 1
エクストラパッケージ
パッケージ名 説明
extra-android-m2repository Android Support Repository, revision 47
extra-google-google_play_services Google Play services, revision 49
extra-google-m2repository Google Repository, revision 58
Hardware_Accelerated_Execution_Manager Intel x86 Emulator Accelerator 7.3.2

Xamarin

Visual Studio for Mac
  • 8.3.3.8
Mono
  • 6.4.0
Xamarin.iOS SDK
  • 13.4.0.2
Xamarin.Android SDK
  • 10.0.3.0
Xamarin.Mac SDK
  • 6.4.0.2
  • 6.2.0.47
Unit Test Framework
  • NUnit: 3.6.1

担当者にお尋ねください

探しているものが見つからなかったでしょうか?

弊社にお問い合わせください