Article version: Enterprise Server 2.16

Error: Repository not found

If you see this error when cloning a repository, it means that the repository does not exist, you do not have permission to access it, or your GitHub Enterprise instance is in private mode. There are a few solutions to this error, depending on the cause.

Check your spelling

Typos happen, and repository names are case-sensitive. If you try to clone git@<em>hostname</em>:user/repo.git, but the repository is really named User/Repo you will receive this error.

To avoid this error, when cloning, always copy and paste the clone URL from the repository's page. For more information, see "Cloning a repository."

To update the remote on an existing repository, see "Changing a remote's URL".

Checking your permissions

If you are trying to clone a private repository but do not have permission to view the repository, you will receive this error.

Make sure that you have access to the repository in one of these ways:

Check your SSH access

In rare circumstances, you may not have the proper SSH access to a repository.

You should ensure that the SSH key you are using is attached to your GitHub Enterprise user account. You can check this by typing the following into the command line:

$ ssh -T git@hostname
> Hi username! You've successfully authenticated, but GitHub does not
> provide shell access.

For more information, see Adding a new SSH key to your GitHub account.

Check if your instance is in private mode

If your site administrator has enabled private mode on your GitHub Enterprise instance, anonymous clones over git:// will be disabled. If you are unable to clone a repository, contact your site administrator.

Check that the repository really exists

If all else fails, make sure that the repository really exists on your GitHub Enterprise Server instance! If you're trying to push to a repository that doesn't exist, you'll get this error.

Ask a human

Can't find what you're looking for?

Contact us